2006年09月26日

うげっ!コンジットでは GData Client Library を使えない!

えー。今頃になって気付きました。

JSync に含まれる JRE のバージョンは 1.3 です。一方 GData Client Library の動作環境としては Java5 が必要です。Genericsを使っているのでソースレベルの互換性も無いのは、昼間弄ったので解っています。

・・・って JSync で GData Client Library 使えへんやんか。

いや、 GData API は基本的にRESTなのだから、 Library を使わず自分で書くのも技術的には全く難しくは無いのですが、認証→セッション管理の辺りがとても面倒です。あうう。結構手軽に作れそうだと思ったのにぃ。。。ぷしゅううううううう。(←モチベーションが一気に縮む音

意地でも Library を使うならサーバサイドでプロクシという手もあるのでしょうが、私はそんなに信頼性の高いサーバを持っていないし。ユーザ側のローカルホストでプロクシ用アプリを別起動させるってのは、さすがに不格好だし。

PalmSourceさぁん。他に何も変えなくて良いから JRE を バージョン5.0 にすげ替えただけの JSync 出してくださいよお。(T_T)
posted by kamicup at 21:06| 兵庫 ☀| Comment(0) | TrackBack(0) | プログラミング | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。

この記事へのトラックバック
×

この広告は1年以上新しい記事の投稿がないブログに表示されております。